Leider ist dieser Deal nicht mehr verfügbar
Abgelaufen

Excel-Tabelle: bestimmte Formel gesucht

8
eingestellt am 2. Aug
Moin!

Ich arbeite gerade an einer Excel-Liste und finde nicht die richtige Formel für mein Vorhaben.

Eine Zelle (z.B. A1) soll das multiplizierte Ergebnis zweier anderer Zellen (z.B. A2 und A3) ausgeben - aber nur, wenn diese größer 0 sind bzw. überhaupt mit einer Ziffer/Zahl befüllt wurden wurden. Wenn keine Zahl oder eine Zahl/Ziffer unter 0 eingetragen ist, soll A1 keinen Wert oder eine 0 anzeigen.

Meine Idee dazu war, mit =WENN() zu arbeiten, konnte aber noch nicht die richtige Lösung finden.

=WENN(A1>"0"; =SUMME(A2*A3); "0") führt zu einem Fehler.
Außerdem hätte ich eben gerne die Option mit drin, dass A1 eine "0" oder eine leere Zelle auswirft, wenn A2/A3 leer sind.

Kann mir dabei jemand helfen?
Freue mich auf eure Antworten.
Zusätzliche Info
Sonstiges
Beste Kommentare
=WENN(UND(A2>0;ISTZAHL(A2));PRODUKT(B2:C3);0)
=SUMMEWENN(A1:A10;"x";B1:B10)
8 Kommentare
=WENN(UND(A2>0;ISTZAHL(A2));PRODUKT(B2:C3);0)
War die Antwort nicht einfacher? 42
g36470102.08.2019 01:09

=WENN(UND(A2>0;ISTZAHL(A2));PRODUKT(B2:C3);0)



Das hat mir sehr geholfen, besten Dank!
g36470102.08.2019 01:09

=WENN(UND(A2>0;ISTZAHL(A2));PRODUKT(B2:C3);0)



Ich bin auf ein weiteres Problem gestoßen, kannst Du mir ggf. nochmal helfen?

Ich möchte ein Gesamtergebnis der Zellen B1 bis B10. Addiert werden sollen jedoch nur die Zellen zwischen B1 und B10, die in der Spalte davor (A1-A10) ein "X" haben.
Das "X" setzt sich selbst durch eine WENN-Bedingung.

Beispielsweise hat nur das Feld B1 und das Feld B5 jeweils einen Wert von 10 und ein "X" in der Zelle davor (also in A1 und A5).
Die anderen B-Zellen haben zwar einen Wert, aber kein "X" in der A-Spalte.
Das Ergebnis wäre "20".

Kann man das mit einer Formel lösen?
kreuzweise02.08.2019 02:19

Ich bin auf ein weiteres Problem gestoßen, kannst Du mir ggf. nochmal …Ich bin auf ein weiteres Problem gestoßen, kannst Du mir ggf. nochmal helfen?Ich möchte ein Gesamtergebnis der Zellen B1 bis B10. Addiert werden sollen jedoch nur die Zellen zwischen B1 und B10, die in der Spalte davor (A1-A10) ein "X" haben.Das "X" setzt sich selbst durch eine WENN-Bedingung.Beispielsweise hat nur das Feld B1 und das Feld B5 jeweils einen Wert von 10 und ein "X" in der Zelle davor (also in A1 und A5).Die anderen B-Zellen haben zwar einen Wert, aber kein "X" in der A-Spalte.Das Ergebnis wäre "20".Kann man das mit einer Formel lösen?


Ja, kann man.
=SUMMEWENN(A1:A10;"x";B1:B10)
FTLG02.08.2019 05:13

=SUMMEWENN(A1:A10;"x";B1:B10)



Dir auch vielen Dank, hat wie geplant funktioniert
kreuzweise02.08.2019 11:29

Dir auch vielen Dank, hat wie geplant funktioniert


Kannst Du das dann bitte als abgelaufen markieren? Danke.
Dein Kommentar
Avatar
@
    Text

    Diskussionen