MyDealz alerts für Linux DEs

8 Kommentare
eingestellt am 4. Dez 2015
Hallo community,
da ich in den letzten tagen immer wieder deals verpasst habe, kam mir die idee, doch einfach mal ein python 3 script zu schreiben, was mich über Gtk Notifications benachrichtigt.
Dabei gibt man in einer Datei an, an welchen Deals man überhaupt interessiert ist und zu welchem Preis. Die Stichwörter werden einfach als reguläre Ausdrücke angegeben.
Wer noch daran interessiert ist, kann sich das script hier herunterladen: github.com/pfa…ert

  1. Diverses
Gruppen
  1. Diverses
8 Kommentare
Avatar

GelöschterUser178172

File "mydealz_alert.py", line 5

^
SyntaxError: invalid syntax


Was mache ich falsch? Aber sau coole Idee. Danke dafür schonmal.

Verfasser

bartmz

File "mydealz_alert.py", line 5 ^ SyntaxError: invalid syntax Was mache ich falsch? Aber sau coole Idee. Danke dafür schonmal.



Gute Frage, auf der Zeile ist ja nur die Lizenz...
Wie versuchst du denn das auszuführen und hast du die abhängigkeiten beachtet?
Avatar

GelöschterUser178172

pfannkuchen_gesicht

Gute Frage, auf der Zeile ist ja nur die Lizenz...Wie versuchst du denn das auszuführen und hast du die abhängigkeiten beachtet?


Hab die wanted.txt in /etc/mydealz gepackt. Und ganz normal mit python mydealz_alert.py über command line ausgeführt. In der wanted.txt steht dein Beispiel.

Edit: python hat ein config fehler bei mir...

Verfasser

bartmz

File "mydealz_alert.py", line 5 ^ SyntaxError: invalid syntax Was mache ich falsch? Aber sau coole Idee. Danke dafür schonmal.



Sehr komisch. Kann den Fehler leider auch nicht reproduzieren. Benutzt du Python 3(.5) oder Python 2? Hast du bs4(BeautifulSoup), pycurl und pygtk installiert?
Steht sonst weiter nichts zu dem Syntaxfehler? Die betroffene Zeile selbst oder sonst irgendwas?
Avatar

GelöschterUser178172

Schein ein bisschen komplizierter zu sein. Wenn jemand das mit Ubuntu zum laufen bekommt, kann er sich ja mal melden.
Liegt aber an mir der Fehler.

Nein, bekomme nur den Fehler, alles installiert. Sowohl Python 2 als auch 3 bringen den Fehler.

Verfasser

Sehr eigenartig. Tut mir leid, dass es erst einmal bei dir nicht funktioniert. Ich werde das evtl. mal mit Ubuntu testen.

Avatar

GelöschterUser178172

pfannkuchen_gesicht

Sehr eigenartig. Tut mir leid, dass es erst einmal bei dir nicht funktioniert. Ich werde das evtl. mal mit Ubuntu testen.


Ja, liegt aber an mir bzw. an meinem System.

Hier wird doch aber bestimmt noch jemand sein der Feedback geben könnte.

Verfasser

pfannkuchen_gesicht

Sehr eigenartig. Tut mir leid, dass es erst einmal bei dir nicht funktioniert. Ich werde das evtl. mal mit Ubuntu testen.



Also ich habe hier ein frisches Ubuntu 15.10 installiert und konnte den Fehler dort ebenfalls nicht produzieren. Allerdings ist mir aufgefallen, dass Ubuntu noch eine alte Version von BeautifulSoup in den repos hat, weshalb nichts gefunden wurde, selbst wenn es einen passenden Deal gab. Hab dafür einen extra branch auf Github erstellt.
Dein Kommentar
Avatar
@
    Text
    Top Diskussionen
    1. Gearbest Zoll Probleme ??!!137515
    2. Gearbest Tracking59
    3. Flug Panama Chile35
    4. mit Hermes aus china?44

    Weitere Diskussionen